Breakout Checkout unavailable

Incident Report for Breakout

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 16:38 UTC

Investigating

We are investigating an issue affecting Breakout Checkout. Customers may be unable to complete checkout at this time. Our team is working to restore service and will provide another update when available.
Posted Jul 20, 2026 - 16:22 UTC
This incident affected: Web (Portal).